| |
| | |

Printer Forum   

 Forgot password?
 register
Search
View: 7711|Reply: 45

'Filter' failed error when printing from EPSON

[Copy link]

Post time: 2013-3-31 11:33:33 |Show all posts
I have an Epson TX420W all-in-one printer, and recently upgraded to OSX Mountain Lion, after reading that I wouldn't have any issues printing after the upgrade. Before the upgrade, I had all Epson drivers up to date (through Software update).
Now when I try to print, after 'Looking up printer', this is what I see:



I can't check the supplies level either.
I checked the EPSON support & drivers page, but couldn't find an updated driver for my printer (only up to 10.7.x)
Does anyone had the same experience or a workaround to this until an driver update comes out?
Thanks in advance!
        MacBook, Mac OS X (10.7.1)

Post time: 2013-4-3 06:42:53 |Show all posts

This is the best advice that I have found. Your advice worked perfectly for me. I have an Epson Stylus SX515W that stoppped working when I moved from using PCs to Macs. Thank you!!!

Post time: 2013-4-3 04:55:24 |Show all posts

I was having the same issue -- I ended up downloading and using the Gutenprint drivers with my Epson C88+. Works flawlessly.
http://sourceforge.net/projects/gimp-print/?source=dlp
Once the drivers were installed I re-added my printer through the System Preferences using the IP form (my printer is attached to a d-link printer server). You will want to manually select the printer type in "Gutenprint" in the filter field to bring up the drivers.
Be aware the Gutenprint drivers don't included scanning functionality and you may need to change your security options for software install to Anyone (I'm using Mountain Lion)

Post time: 2013-4-3 03:24:33 |Show all posts

Welcome to the world of Mac, ddorf, and congratulations on joining us! I'm sorry to say that you've stumbled on one of the more unusual and frustrating problems I've known through 30 years and every version of the Mac OS. I've had the 'filter failed' problem a few times in the last few months but, right now, my Mac and ageing Epson all-in-one printer/copier/scanner are working happily - and am not sure that any of the ideas above has helped. Each time I've had the problem, things have come back to normal sooner or later after switching off the printer for a few minutes and allowing it to restart/reboot its own internal software. Ensure, too, that you keep your software up to date and use the most recent drivers. Sometimes, simply opening the print queue, deleting its contents, quitting it and then trying anew seems to have helped. Hope this helps - sooner or later, Apple will fix the issue!
Mark

Post time: 2013-4-3 02:18:39 |Show all posts

I'm a new Mac user with a brand new machine. I'm having the same 'filter failed' printing problem that others have. I have a Kyocera network printer FS-C5200DN. I spent about an hour with the Apple hotline desk, which wasn't able to help me. I called Kyocera, which couldn't help me immediately but is looking into the issue.
Can anyone help me? I'd really appreciate some troubleshooting tips.
Thanks.

Post time: 2013-4-3 00:47:10 |Show all posts

That was brillant. I worked for three hours and then found your trick and it works. I had already deleted the printer and reloaded the driver from Apple to no avail. Thanks.

Post time: 2013-4-2 23:27:02 |Show all posts

Some of these issues with 'filter error' occur when you try to print something that is outside of the printers printable area. Another cause can be when the printer is out of ink, toner or some other supply issue. Check both of these when you have issues before looking at drivers or other more involved faults!

Post time: 2013-4-2 21:29:28 |Show all posts

FIXED IT. I have an Epson Photo Stylus R220 printer connected to a NAS server (BlackArmor 220) and could not print with the Epson drivers. I downloaded the driver set from Gutenprint and worked perfectly the first time.
http://gimp-print.sourceforge.net/MacOSX.php

Post time: 2013-4-2 20:07:12 |Show all posts

It's the same error on the surface - "filter failed," but it's not the same filter since you are using an HP; the error here has to do with EPSON/InkjetPrinter2/Filter/rastertoescpII, and it is printer related. You'll see that a different filter failed if you look in the cups log.

Post time: 2013-4-2 18:34:24 |Show all posts

Hello,
I had the same "Filter failed" error, but with an HP M1120n printer and only after upgrading to 10.8 Mountain Lion.
Reading forums and discussions I found, I realised that it was not printer related, but Mac OS related.
I tried everything which was suggested in this thread, that's re-initializing print center, repair permission, re-installing original manufacturer driver, downloading and installing the full HP package from Apple, restarting in between… but nothing worked. I could not anymore add the printer and got a bad driver installation message, something finishing by "reinstall the original manufacturer package" which I could not do because the installation CD was too old and gave an error on 10.8.
Finally I found something on an HP support discussion about adding the printer but NOT the one appearing in the proximity (local) menu. I opened the Add dialog, select the printer, and, most important, in the Use (driver) dropdown menu, I did not choose automatic, nor the HP driver which was selected, but I choosed "Select printer Driver" and in the next window I choosed the driver corresponding my printer model. Note that it had the exact same name as the one suggested before, but it did made the difference and the printer was correctly added.
And moreover, it works :-)
Maybe this might help others.

Post time: 2013-4-2 17:32:53 |Show all posts

Epson link doesn't take you to the correct webpage. Just go to the FAQ section, click error messages, and click on the 6th question down:
When I try to print form a USB or WIFI connection I see this error message:

Post time: 2013-4-2 16:28:30 |Show all posts

After about 8 hours of frustration I fnally got my Epson Workforce 600 to print again. Here's the step by step solution I found.
http://www.epson.com/cgi-bin/Store/support/supDetail.jsp?BV_UseBVCookie=yes&info Type=FAQ&oid=110566&prodoid=63076679&foid=162869&cat=30961&subcat=30956
After removing from hardrive I downloaded the latest drivers;
http://support.apple.com/kb/DL1398
The Epson scanner software still doesn't work because PCPower applications are no longer supported be Lion/Moutain Lion. Just use the Image Capture App, it worked for me.

Post time: 2013-4-2 15:11:47 |Show all posts

Within a few days of my post Apple had an update that contained drivers for Epson printers. That didn't work. But it did give me enough numerical information to go looking for newer drivers. I found a driver of a different release that solved my problem. Thank goodness. I was not looking forward to buying another printer just when Costco decided to fill those particular ink cartridges.

Post time: 2013-4-2 13:50:12 |Show all posts

I was also having this error - updated all firmware etc without a fix and then finally realised that the print settings were set to print even pages only and I was selecting an odd page I wanted to print, hence the filter error message.
User error in my case.
Might be worth checking the preferences haven't changed in error to only print even or odd pages?

Post time: 2013-4-2 12:41:23 |Show all posts

Ok I got it to work!!!! I had downloaded a drives from somewhere on the net....EPSONprinterdrivers2-5.11dmg. It prints! This was not the driver from the App Store software update.....

Post time: 2013-4-2 11:09:23 |Show all posts

Didn't work...still can't print.

Post time: 2013-4-2 09:30:20 |Show all posts

Thank you that's what I thought you meant but I don't use Chrome. BUT...got 3 update notices from Apple about 10 minutes ago. One of them is an Epson driver update. I sure hope that fixes the problem. What a vexing problem this has been. Epson hasn't a clue and what they told me to do was useless and time consuming. I kept telling them that there were no update for the Epson, they kept telling me the same stuff over a over. I'm crossing my fingers!

Post time: 2013-4-2 08:01:07 |Show all posts

"Chrome" is the Google Chrome browser ... but in my case that was a bogus issue.
The entire problem in my case was that the printer was incorrectly identifying the gateway (router) IP address when it automatically tried to join the network.
I have a theory on why that happened: My desktop computer had WiFI on and the printer MAY have grabbed THAT address instead of the router address. So I figured out the IP address of the router (I'm using an Apple router so I used Airport Utility) and I entered it manually. It's worked perfectly ever since.
Make sense?

Post time: 2013-4-2 06:24:26 |Show all posts

What the heck is Chrome? I have the same problem.

Post time: 2013-4-2 04:33:18 |Show all posts

Interesting that Apple thought it may be a Chrome and ML issue. I'll watch today. I did a full re-install of the Apple Epson drivers with chrome closed last night, printed perfectly from Pages and Preview. Waiting to see what gremlins were at play overnight. I printed via USB and Airprint.
You have to log in before you can reply Login | register

Advertise on OASQ.COM| Contact us| Archive| OASQ

2014-10-21 23:59 GMT-8

Powered by Discuz! 7.2

Release 20121101, © 2001-2014 OASQ.

To Top